Adverti horiz upsell

Nightshade UV Editor 2.1.3 for Maya (maya script)

Nightshade UV Editor extends the Maya's UV Texture Editor with tools, scripts and a UI that greatly speed up the time it takes doing UV work.

License
Button download
26,901 Downloads

Compatibility

  • 2017, 2016, 2015, 2014, 2013

Operating Systems

  • Mac
  • Windows

History

Created:09/11/2012
Last Modified:09/11/2016
File Size: 3.2 MB

Q/A

Double select objects to show UVs?

Date:08/11/2015
Submitted by: Geta-Ve Geta-Ve
Not sure if this is a ME issue or not, but I've only noticed it when updating to 2.0 (running Maya 2016). When selecting objects (that have been previously unwrapped) I have to select that object twice in order to actually see the corresponding laid out UV's in the NSUV window.

I feel like I may be doing something silly here, or forgetting to turn on a preference in Maya (I have been away from Maya for a bit) but I figured I would inquire just in case this was an issue with NSUV.

Thanks for the hard work sir!! :) 

Replies to this question:

  • Martin Dahlin

    Martin Dahlin said over 6 years ago:

    Interesting - this is the first time I hear about this. NSUV has script jobs for updating the editor and the UV set list - basicly scripts which are executed when certain events are triggered in Maya. Those events are: SelectionChanged SelectTypeChanged SelectModeChanged Which means that for some reason, Maya doesn´t recognize your first selection as a "SelectionChanged" -event. Go into the script editor > history, and check the top four checkboxes. Then run the Python code below and see what happens in the script editor log when you select your meshes. (You should see the text "scriptJob ran" every time your selection changes) import pymel.core as pm def testPrint(): print("scriptJob ran") pm.scriptJob( event=["SelectionChanged", lambda *args: testPrint()], ) pm.scriptJob( event=["SelectTypeChanged", lambda *args: testPrint()], ) pm.scriptJob( event=["SelectModeChanged", lambda *args: testPrint()], )
  • Replyindent
    Geta-Ve

    Geta-Ve said over 6 years ago:

    Alright, so after the SP1 update and your update things seem to be working as intended now. I'll get back to you if it changes. Thanks for the help! :D
  • Replyindent
    Martin Dahlin

    Martin Dahlin said over 6 years ago:

    No worries. Let me know if you got things working. I suggest that you download the latest service pack for your version of Maya. It's a long shot but it might resolve your issue.
  • Replyindent
    Geta-Ve

    Geta-Ve said over 6 years ago:

    Apologies! I have not forgotten about this. I just have had basically zero time to investigate further. Hopefully I will have a proper response for you by end of next week. Thanks for the quick response though!!
  • Martin Dahlin

    Martin Dahlin said about 6 years ago:

    Strange, I thought I had replied to you once already but it appears that my reply simply vanished - and now Im sure some other post is missing as well. Sigh. Anyway this is where you toggle on the checkers in the editor: https://oi62.tinypic.com/swsmyh.jpg
  • Replyindent
    Geta-Ve

    Geta-Ve said about 6 years ago:

    You did! 3 times already. lol. I can still see your posts. :O Thank you for replying again however! I really appreciate the care and attentiveness!

Post a reply: